Using Mikogo on Mac OS X 10.6 Snow Leopard

If you are a user of Mac OS X 10.6 (a.k.a. “Snow Leopard”) you will have seen that Apple has ceased releasing patches or security updates for your operating system. Consequently, this has made life harder for our development team. We have had to develop the Mikogo software for the latest Mac operating systems (i.e. Mavericks, Yosemite and El Capitan) with all the new patches and security updates, while simultaneously maintaining compatibility with the outdated OS X 10.6.

In light of Apple's move away from 10.6, it is not feasible for us to continue supporting an outdated operating system, while we concurrently work on developing new Mikogo releases for the latest Mac operating systems.

The far majority of Mac users are moving towards the latest versions of Mac OS X and we feel that we can better support our user base and provide greater new features, if we focus our time on those operating systems.

Good news!

This does not mean that Mac OS X 10.6 users cannot use Mikogo. It only means that when we develop new Mikogo releases, we will not include OS X 10.6 as one of our supported operating systems. It means that new Mikogo releases and features (after October 2015) may not run normally on OS X 10.6.

The good news is that the current latest version of Mikogo (Mikogo Version 5.2) has been thoroughly tested and is 100% compatible with Mac OS X 10.6. We will keep Mikogo 5.2 and continue to make it available. Users of 10.6 Snow Leopard are very welcome to use Mikogo 5.2 and to continue hosting and joining Mikogo meetings.

Click one of the links below to download Mikogo 5.2 – compatible with Mac OS X 10.6 Snow Leopard:

Organizer Download:

Participant Download:


We understand that for Mac OS X 10.6 users that this news comes as an inconvenience. We apologize for this and hope you can understand our decision here.

Have more questions? Submit a request


Please sign in to leave a comment.
Powered by Zendesk